March, 2026
Incident Updates
Sunday, March 1st
No Incidents
Monday, March 2nd
No Incidents
Tuesday, March 3rd
RESOLVED
Outage of upstream provider
Started 1 day ago, lasted for 30 minutes
Updates
- RESOLVED
Hetzner has resolved the issue, all services are healthy. https://status.hetzner.com/incident/1c082fde-fe61-40b0-ab41-8d4d7deaf6fe
- INVESTIGATING
Due to an issue with our upstream provider (hetzner.com), all services are unreachable.
Wednesday, March 4th
No Incidents
Thursday, March 5th
No Incidents